Monthly Archives: September 2012

Internet Explorer Zero-Day: Don’t use IE as your browser

There’s a really VERY serious exploit for Internet Explorer. IE versions 7 to 9 in Windows XP through Win 7 are vulnerable. If you haven’t updated in a while, you really need to. Please have/make a backup, and update.

See http://nakedsecurity.sophos.com/2012/09/17/new-ie-zero-day-exploit-poison-ivy/
and
https://krebsonsecurity.com/2012/09/exploit-released-for-zero-day-in-internet-explorer/ for more info.

The only time you should really use IE is for Windows Update(s).